ViewSign Desktop Advanced Guide Tabs

From ViewSonic User Guide Database
Jump to navigation Jump to search
Backtotop.svg

Tabbed Menu

All of ViewSign Desktop's software features are accessible through the menu items organized into tabs and groups. The style of the entire user interface is inspired by the style of Microsoft Office applications. To enable the different cards you have to create a file, import at least a document and jump to it. The various buttons are active or not in accordance with certain conditions. The details of various boards and the accompanying buttons is shown in the sections below

Each tab contains the controls or buttons groups, each group contains one or more controls. Overall, the menu structure is as follows:

HOME EDIT GRAPHOMETRIC SIGNATURE DIGITAL SIGNATURE UTILITY BOOKMARKS
  • Dossier
  • Save
  • Document
  • Slideshow
  • Compile
  • Document
  • Objects
  • Rotate the Document
  • Select
  • Creation
  • Manage
  • Inserting
  • Digital Signature Options
  • Utilities
  • User's Guide

Home Tab

ViewSign Desktop Advanced Home.png

Item Description Status Rules
Add Document Opens a window that allows you to add documents to the skeletal structure of one or more selected files. Also available.
Add Document from Model It has the same functionality of the button Add Document with the difference that it creates a physical copy of the selected file and adds it to the tree structure. Also available.
Add from Scanner Allows you to scan a document and import the tree of documents / attachments (in the case of documents with attachments) into the pdf product. Always available.
Add Attachment Opens a window that allows you to add documents to the tree, in the Attachments node, User can add one or more selected files. Only available in a file with attachments.
Add FEA Information Allows two choices: start a Wizard that guides the user in completing the FEA (Advanced Electronic Signatures) document, or attach a pdf document prepared for existing FEA structure. Always Available.
Merge Files Allows to unify all the selected documents in the tree as files to merge into a single document. The unified file is renamed and added to the tree structure. Available only in simple file and only if you have selected at least two nodes of the tree.
Generate Single Document Allows you to merge the files that are in the "Documents" folder with the files that are in the "Attachments" folder. All these files are merged into a single file that is renamed according to the set rules and then added to the tree of documents. Only available in the file with attachments.
Remove Document Removes all the files from the tree (nodes) selected. Available if there is at least one selected leaf node.
Move Up Change the order of a file in the tree view of documents. Move up a selected file. Available if: there are at least two documents in the tree or the file's location in the tree of documents is different in the first.
Move Down Change the order of a file in the tree view of documents. Moves below a selected file. Available if: there are at least two documents in the tree or the file's location in the tree of documents is different from the last.
Confirm Changes Save in pdf the following changes: Adding pages, Handwrite, Add images, Add Text, Adding digital stamps, page rotation, or the entire document, Creating signature fields Save in the memory area associated with the file of the signature areas not yet transformed into signature fields. Available if it is performed at least one of the operations listed next. It is turned off immediately after saving the changes.
Undo Changes Reload the document since the last save. Available if at least one of the above actions is performed. It is turned off immediately after loading / undo changes made to the document.
Print Execute the print operation on the single selected document or all the documents. Available if there is at least one document to be printed in the tree of documents.
Protect Document  Create a password to read the document, if the document is not already protected by a password.  Only available in the documents entitled to protection, i.e. documents without reading any protection.
Flatten Document  Removes all acrofields provided or only the signature fields from the document, depending on document structure.  Available only if the document contains at least one acrofield.
Export Fields in XML  Create an XML file with the structure defined in the Options.  Available only if the document has exportable acrofields fields (such as text fields).
Sign all Files  Performs a bulk Graphometric signature on all documents tree. Regardless of the user selection.  Available only in simple file and if there are at least two documents in the tree.
Check Document  Performs a verification of digital signatures on the document.  Only available if the document exists at least one digital signature.
Send Document  Composes an email message which attaches selected documents in the tree or all files in the file, based on the user's choice.  Also available.
Upload with FTP  Allows you to send either the individual document or all the documents in the file to a remote folder using the FTP protocol according to your settings.  Always Available.
File Protocol  Allows you to place a protocol number to the document being imported in the file.  Personalization only available in some versions of the software depending on the installed components.
Start Slideshow  Start rotating presentation of slide images, depending on the settings in Options, on the secondary monitor or on other extended displays connected to your PC.  Available if the presentation images are not already started.
Stop Slideshow  Stops displaying the slide images previously initiated.  Available if the presentation images are still actively looping.

Edit Tab

ViewSign Desktop Advanced Edit.png

All of these features are available only if the selected document has not been previously digitally signed.

Item Description Status Rules
Fill PDF Depending on the user choice in Options > Preferences > Use plug-in Adobe.
  • If selected, opens the current document in a new window using the Adobe Reader plug-in component distributed with ViewSign Desktop . Allows the user to compile editable PDF fields (such as text fields, multiple choice boxes).
  • Alternatively, you can compile the edit fields using an integrated tool native to ViewSign Desktop . When using this Namirial tool, all of the ViewSign Desktop buttons will be temporarily disabled until the user chooses one of the two options: Save and Close, or Cancel and Close.
 Only available if the document contains acrofields to compile.
Compile on External Device Opens a full screen on the secondary monitor that is set in ‘Options’. This is a window for editing of the document acrofields.  Only available if the document contains acrofields to compile.
Add Page Append a blank page to the document.  Always Available.
Edit on External Device  Opens the current document in a new window. This window is loaded in full screen mode last available external monitor. It allows the user to write freehand in the document. Available if there is at least a second monitor.
Pen Allows you to set the pen color (black, red, blue, green) of the section in the current document and write freehand.  Always Available.
Insert Image Allows you to add an image in the document. The user can choose whether to load an existing image file, or take a picture using a webcam connected to the host PC.  Always Available.
Add Text Allows you to add text in the current document. The text you type is inserted into a text box, single line, and then placed inside the document.  Always Available.
Insert Stamp If a default stamp was chosen, this stamp is designed around the mouse cursor at the location in the document where a mouse-click is executed. If a stamp is not defined, opens the window for entering the stamp selection. The user may place the current stamp in multiple locations within a document. You can navigate between pages using the mouse scroll. To finish entering the stamp you must click on the ‘Select’ button or keyboard press the ‘Esc’ button.  Always Available.
Rotate Page (Counter-Clockwise) Rotate counterclockwise the current page of the active document 90/180/270 degrees. The value is selected by the control ‘angle rotation’.  Always Available.
Rotate Page (Clockwise) Rotate clockwise the current page of the active document 90/180/270 degrees. The value is selected by the control ‘angle rotation’.  Always Available.
Rotate Document (Counter-Clockwise) Rotate counter-clockwise all the pages of the active document 90/180/270 degrees. The value is selected by the control ‘angle rotation’.  Always Available.
Rotate Document (Clockwise) Rotate Clockwise all the pages of the active document 90/180/270 degrees. The value is selected by the control ‘angle rotation’.  Always Available.
Select Objects Allows you to select any of the following items included in the document but not yet finalized on the ‘Confirm’ button. Selection can be used on graphics, text, images, and stamps.  Available only if you select any of the forms described above.
Clear Object Allows you to delete any of the objects specified above so they will not be saved in the document.  Available only if you select any of the forms that can be eliminated.

Graphometric Signature Tab

ViewSign Desktop Advanced Graphometric Signature.png

In this tab, you can perform all the operations regarding graphometric signature. You can create signature areas, signature fields, apply templates and start signing flows.

Item Description Status Rules
Add Signature Area Initiates an orange rectangle, which is placed into the document with a single mouse-click. Place this rectangle in every location that you want to have an active area for adding a signature. It creates a signature field and you can apply a graphometric signing in this area. You can continue to affix signature fields in the document, from page to page with the mouse scroll. you must click on the button "Select" or press the "Esc" key on your keyboard to end the state of adding signature areas.  Always available. The button color changes when the button is selected.
Expand Signature Area Increase the size, in a progressive manner, of the painted area around the cursor. Expand the area by dragging a corner of the rectangle.  Only available if you choose the first "Add signature area."
Reduce Signature Area Decreases the size, in a progressive manner, of the painted area around the cursor. Decrease the area by dragging a corner of the rectangle.  Only available if you choose the first "Add signature area."
Create Template Load from file, with extension fct, a previously saved signature template. Eliminates signature areas present and loads the settings saved in the template. If the document contains signature fields, the template signature areas are appended to existing fields.  Always available.
Create Pattern Allows you to create signature areas according to the search pattern specified in the options in the current document. The search patterns are strings of text that represent the key words to search within the document. A signature is created around the identified words whenever ViewSign Desktop finds a string that starts with or contains the chosen pattern.  Always available.
Create Tag Signature Create signature area around the word # # signature as specified in the section "Setting Pattern".  Always available.
Select  Select an area of signature or the signature field in the document.  Only available if there is an area / field signature to be selected.
Previous Signature  View previous signature field if it exists. Available if a field / signature area exists and is not selected first on the list. 
Next Signature  Display the next signature field if it exists.  Available if a field / signature area exists and was not selected last on the list.
Hello Template  Opens a window that allows the user to choose template files with fct extension, and save the template to the current signature. The file will contain all signing areas positioned within the document as defined in the template.  Available if you have created at least one area of the signature.
Convert into Signature Field  Transform the area selected into a signature field.  Available if you select an area and the document has not yet been digitally signed.
Remove Signature  Removes the selected signature area / field.  Only available if you selected an area / signature field.
Immediate Signature  Creates a signing area and Graphometric signing procedure in the location on the document indicated by the cursor and the mouse click. The signature can also be applied on all pages of the document in the same location of the first signature. To do this you simply choose the menu item ‘Signature on all pages’.  Always available.
Single Signature  Allows you to affix a graphometric signature with the click of the mouse, in a new signature field indicated by the cursor location.  Always available.
Signature Full Flow  Starts a graphometric signing procedure all fields / signature areas in the current document.  Always available.

Digital Signature

ViewSign Desktop Advanced Digital Signature.png

This tab provides tools with functionality to digitally sign a PDF file. The digital signature is PAdES format. The digital signature settings can be customized from the options. In File > Options > Digital Signature, and File > Options > Logo pdf.

Note: Disabled for North American Installations
Item Description Status Rules
Sign Starts the digital signature process the document. If a smart card or micro SD is present with the logo for the digital signature this logo appears in the document by default. The digital signature can also be invisible. You must specify the option "Do not show the signature logo in pdf documents." Always available.
Signature Timestamp Perform the steps above and also affixes a time stamp according to the parameters specified in the options. Always available.
Counter Sign Performs a countersignature on the current document. The countersignature or "Signature matriosca" indicates that each signature added to the document and pertains to the previous signatures CAdES format. Look for more information at: https://www.agid.gov.it/sites/default/files/repository_files/linee_guida/firme_multiple.pdf You can countersign a document only if you have previously signed.
Timestamp Append a time stamp in the current document. It connects to the TSA service indicated in the options according to the configured account. The time stamp inherits the logo and the additional test settings of the digital signature. Always available.

Utility

ViewSign Desktop Advanced Utility.png

This tab allows you to access other functions not directly related to the digital signature and/or Graphometric workflows and processes. These additional settings are configured for use of proprietary Namirial SPA signature services.

Registration and License graphometric signature: To affix a graphometric signature and request a license for a signature that must have a certificate issued by Namirial SPA.. The user license is nominal and valid for a single PC. So it's required at the initial installation and eventually moved to another machine if necessary. All functions related to licensing are accessible via the "Register" button.

Item Description Status Rules
Registration Starts a Wizard that allows you to do the following: Apply for a license for the graphometric signature, check the status of an existing license in the device, view the details of an existing license, recover a license. Always available.
Check for Updates Start the function ‘Namirial Upgrade’, which researches and notifies the user of updates to be downloaded and starts the installation. The installation of a new version will require the closure of ViewSign Desktop . Always available.
Install Medium Certificate Install in the PC into a medium signing certificate from Namirial SPA. Always available.
Remove Medium Certificate Allows you to choose and remove medium installed certificates from the computer. Always available.
Change/Unblock PIN Allows you to: Unlock the smart card / micro SD pin, change the current pin with a new one specified by the user. Always available.
Set Digital Signature Logo Allows you to customize the logo to be used for digital signature and time stamp. Only available when using a smart card or micro SD as a digital signature device.
Enable Signature Device It allows you to perform the first activation of the device for digital signatures: Smart card or micro SD. Always available.

Bookmarks

The Bookmarks tab is a default tab that is empty because the user can add all of the available buttons based on preference. This is to speed up and simplify the use of the software and create a better user experience by creating a selection of workflow shortcuts to features that are frequently used.

Example: If in a given workflow, a hypothetical User must always do the same tasks: Customer recognition through identification, Advanced Electronic signature, tab completion, and finally digital signature. The User can personalize the Bookmarks and add in the order most appropriate ViewSign Desktop buttons to match process to the workflow above in order to improve productivity and user experience. User would add the Capture from scanner button, then add FEA (Advanced Electronic signature), fill pdf, complete flow signature.

To customize the Bookmarks tab just choose: File > Bookmarks.

ViewSign Desktop Advanced Bookmarks 1.png

On the left side of the window are shown all the available buttons. Selecting one, you can add it to the right column. Selecting an item from the right column you can remove, or reorder. The order is from left to right.

ViewSign Desktop Advanced Bookmarks 2.png

The right column contains all the buttons that are added in the Bookmarks tab. In the tab you can create groups. As seen in the example groups were created according to the hypothetical flow described above.

ViewSign Desktop Advanced Bookmarks 3.png